ZaLinux.ru

Ошибка «The engine “node” is incompatible with this module» (РЕШЕНО)

Ошибка «The engine "node" is incompatible with this module» означает, что node не совместим с указанным модулем. То есть устанавливаемая программа требует более высокую версию npm чем присутствует в системе.

Такая ошибка может возникнуть при использовании yarn (устанавливает зависимости):

yarn

Пример вывода:

yarn install v1.22.4
[1/5] Validating package.json...
error javascript-obfuscator-web@3.3.5: The engine "node" is incompatible with this module. Expected version ">=12.13.1". Got "10.20.1"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Начните с обновления Node.js и NPM из стандартных репозиториев вашей системы, также обратитесь к статье «Установка последних версий Node.js и NPM в Linux».

Следующие команды являются самым быстрым способом исправить проблему, но он не рекомендуется на production серверах, т. к. может смешать глобальные пакеты npm. Тем не менее, он самый быстрый и действенный:

sudo npm cache clean -f
sudo npm install -g n
sudo n stable

Для обновления до последней версии (а не текущей стабильной) вы можете использовать:

sudo n latest

Чтобы изменения вступили в силу может потребоваться закрыть и открыть консоль. Либо выполните:

PATH="$PATH"

Рекомендуемые статьи:

Оставить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *